Exotel Status Board
Home
Dashboard
BETA
28th September 2024
Gujarat
Issue observed for 'Incoming Calls' in Gujarat Region
Identified at [28/09/24 05:30 PM] with 'Major Outage'
Issue has been resolved at [28/09/24 05:50 PM]