BETA

25th September 2024

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [25/09/24 01:55 PM] with 'Partial Outage'

Issue has been resolved at [25/09/24 02:00 PM]