Exotel Status Board
Home
Dashboard
BETA
14th September 2024
Indonesia
Issue observed for 'Incoming Calls' in Indonesia Country
Identified at [14/09/24 05:00 AM] with 'Major Outage'
Issue has been resolved at [14/09/24 05:10 AM]