BETA

13th October 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [13/10/17 04:02 AM] with 'Partial Outage'

Issue has been resolved at [13/10/17 04:03 AM]