Exotel Status Board
Home
Dashboard
BETA
28th August 2024
Indonesia
Issue observed for 'Outgoing Calls' in Indonesia
Identified at [28/08/24 10:40 PM] with 'Major Outage'
Issue has been resolved at [28/08/24 11:00 PM]