Exotel Status Board
Home
Dashboard
BETA
27th August 2024
Gujarat
Issue observed for 'Incoming Calls' in Gujarat Region
Identified at [27/08/24 06:25 PM] with 'Major Outage'
Issue has been resolved at [27/08/24 06:47 PM]