BETA

12th October 2017

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [12/10/17 08:48 PM] with 'Major Outage'

Issue has been resolved at [12/10/17 08:49 PM]