Exotel Status Board
Home
Dashboard
BETA
24th August 2024
Kerala
Issue observed for 'Outgoing Calls' in Kerala Region
Identified at [24/08/24 08:50 AM] with 'Major Outage'
Issue has been resolved at [24/08/24 09:15 PM]