Exotel Status Board
Home
Dashboard
BETA
19th August 2024
Gujarat
Issue observed for 'Incoming Calls' in Gujarat Region
Identified at [19/08/24 10:25 AM] with 'Major Outage'
Issue has been resolved at [19/08/24 11:10 AM]