Exotel Status Board
Home
Dashboard
BETA
18th August 2024
Gujarat
Issue observed for 'Incoming Calls' in Gujarat Region
Identified at [18/08/24 06:22 PM] with 'Major Outage'
Issue has been resolved at [18/08/24 06:50 PM]