BETA

12th October 2017

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [12/10/17 06:24 PM] with 'Major Outage'

Issue has been resolved at [12/10/17 06:25 PM]