Exotel Status Board
Home
Dashboard
BETA
13th August 2024
Rajasthan
Issue observed for 'Incoming Calls' in Rajasthan Region
Identified at [13/08/24 08:10 PM] with 'Major Outage'
Issue has been resolved at [25/10/24 01:05 AM]