BETA

12th October 2017

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [12/10/17 04:09 PM] with 'Major Outage'

Issue has been resolved at [12/10/17 04:10 PM]