BETA

8th August 2024

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [08/08/24 12:55 PM] with 'Partial Outage'

Issue has been resolved at [08/08/24 01:00 PM]