Exotel Status Board
Home
Dashboard
BETA
6th August 2024
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [06/08/24 04:45 PM] with 'Major Outage'
Issue has been resolved at [07/08/24 12:02 AM]