BETA

4th August 2024

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [04/08/24 01:30 AM] with 'Partial Outage'

Issue has been resolved at [04/08/24 02:05 AM]