BETA

2nd August 2024

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [02/08/24 09:25 AM] with 'Major Outage'

Issue has been resolved at [02/08/24 09:35 AM]