BETA

12th October 2017

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [12/10/17 02:33 PM] with 'Major Outage'

Issue has been resolved at [12/10/17 02:34 PM]