Exotel Status Board
Home
Dashboard
BETA
1st August 2024
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [01/08/24 12:25 AM] with 'Major Outage'
Issue has been resolved at [01/08/24 12:35 AM]