Exotel Status Board
Home
Dashboard
BETA
30th July 2024
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [30/07/24 01:35 AM] with 'Major Outage'
Issue has been resolved at [30/07/24 01:40 AM]