BETA

29th July 2024

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [29/07/24 11:50 PM] with 'Partial Outage'

Issue has been resolved at [30/07/24 12:35 AM]