BETA

12th October 2017

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [12/10/17 11:52 AM] with 'Major Outage'

Issue has been resolved at [12/10/17 11:53 AM]