Exotel Status Board
Home
Dashboard
BETA
28th July 2024
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [28/07/24 10:00 AM] with 'Major Outage'
Issue has been resolved at [28/07/24 10:05 AM]