Exotel Status Board
Home
Dashboard
BETA
25th July 2024
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [25/07/24 12:45 PM] with 'Major Outage'
Issue has been resolved at [25/07/24 12:55 PM]