BETA

12th October 2017

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [12/10/17 01:17 AM] with 'Major Outage'

Issue has been resolved at [12/10/17 01:18 AM]