Exotel Status Board
Home
Dashboard
BETA
22nd July 2024
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [22/07/24 11:35 AM] with 'Major Outage'
Issue has been resolved at [22/07/24 11:40 AM]