BETA

12th October 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [12/10/17 12:32 AM] with 'Partial Outage'

Issue has been resolved at [12/10/17 12:33 AM]