Exotel Status Board
Home
Dashboard
BETA
15th July 2024
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [15/07/24 03:35 PM] with 'Major Outage'
Issue has been resolved at [15/07/24 03:47 PM]