Exotel Status Board
Home
Dashboard
BETA
11th July 2024
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [11/07/24 06:00 AM] with 'Major Outage'
Issue has been resolved at [11/07/24 06:11 AM]