Exotel Status Board
Home
Dashboard
BETA
10th July 2024
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [10/07/24 03:00 AM] with 'Major Outage'
Issue has been resolved at [10/07/24 03:05 AM]