BETA

9th July 2024

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [09/07/24 02:05 PM] with 'Major Outage'

Issue has been resolved at [09/07/24 02:15 PM]