Exotel Status Board
Home
Dashboard
BETA
4th July 2024
Chennai
Issue observed for 'Outgoing Calls' in Chennai Region
Identified at [04/07/24 10:30 PM] with 'Major Outage'
Issue has been resolved at [04/07/24 11:30 PM]