Exotel Status Board
Home
Dashboard
BETA
29th June 2024
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [29/06/24 05:50 AM] with 'Major Outage'
Issue has been resolved at [29/06/24 05:55 AM]