BETA

28th June 2024

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [28/06/24 12:50 AM] with 'Major Outage'

Issue has been resolved at [28/06/24 01:01 AM]