Exotel Status Board
Home
Dashboard
BETA
25th June 2024
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [25/06/24 06:40 AM] with 'Major Outage'
Issue has been resolved at [25/06/24 06:45 AM]