BETA

11th October 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [11/10/17 06:03 PM] with 'Partial Outage'

Issue has been resolved at [11/10/17 06:04 PM]