BETA

21st June 2024

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [21/06/24 12:12 PM] with 'Partial Outage'

Issue has been resolved at [21/06/24 12:15 PM]