Exotel Status Board
Home
Dashboard
BETA
20th June 2024
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [20/06/24 12:30 PM] with 'Major Outage'
Issue has been resolved at [20/06/24 12:35 PM]