BETA

11th October 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [11/10/17 05:55 PM] with 'Major Outage'

Issue has been resolved at [11/10/17 05:56 PM]