Exotel Status Board
Home
Dashboard
BETA
16th June 2024
Andhra Pradesh
Issue observed for 'Incoming Calls' in Andhra Pradesh Region
Identified at [16/06/24 12:06 PM] with 'Major Outage'
Issue has been resolved at [16/06/24 12:10 PM]