BETA

15th June 2024

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [15/06/24 01:55 PM] with 'Major Outage'

Issue has been resolved at [15/06/24 02:06 PM]