Exotel Status Board
Home
Dashboard
BETA
14th June 2024
Andhra Pradesh
Issue observed for 'Incoming Calls' in Andhra Pradesh Region
Identified at [14/06/24 01:30 AM] with 'Major Outage'
Issue has been resolved at [14/06/24 01:40 AM]