Exotel Status Board
Home
Dashboard
BETA
11th June 2024
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [11/06/24 11:25 AM] with 'Major Outage'
Issue has been resolved at [11/06/24 11:30 AM]