BETA

11th October 2017

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [11/10/17 05:08 PM] with 'Major Outage'

Issue has been resolved at [11/10/17 05:10 PM]