BETA

11th October 2017

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [11/10/17 04:41 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [11/10/17 05:18 PM]