BETA

4th September 2016

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [04/09/16 10:21 PM] with 'Partial Outage'

Issue has been resolved at [04/09/16 10:46 PM]