Exotel Status Board
Home
Dashboard
BETA
2nd June 2024
Andhra Pradesh
Issue observed for 'Outgoing Calls' in Andhra Pradesh Region
Identified at [02/06/24 03:05 AM] with 'Major Outage'
Issue has been resolved at [02/06/24 03:50 AM]