BETA

27th May 2024

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [27/05/24 03:45 AM] with 'Major Outage'

Issue has been resolved at [27/05/24 03:50 AM]