BETA

11th October 2017

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [11/10/17 04:39 PM] with 'Partial Outage'

Issue has been resolved at [11/10/17 04:40 PM]