Exotel Status Board
Home
Dashboard
BETA
25th May 2024
Gujarat
Issue observed for 'Incoming Calls' in Gujarat Region
Identified at [25/05/24 10:40 AM] with 'Major Outage'
Issue has been resolved at [25/05/24 02:56 PM]